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Installation

1 Minimum system requirements

Operating system 64-bit version of:

￭ Windows 11 Pro / Enterprise
￭ Windows 10 Pro / Enterprise
￭ Windows Server 2022
￭ Windows Server 2019
￭ Windows Server 2016

RAM 8 GB

Hard disk space Program: 1 GB

Data:

￭ Minimum: 10 GB
￭ Recommended: 50 GB

USB ports for devices with USB interface

Screen Minimum resolution: 1024 x 768

Network 10 Mbit/s, stable and permanent

Communication via TCP/IP

Safety systems, e.g. firewalls, have an impact on
performance.

PDF reader A PDF reader must be installed on the computer.

The Windows user must have administrator rights in order to be able to install
the StabNet software.

2 Customizing energy options

During the determination, data loss may occur or there may be communication
problems with certain energy options of the operating system. Proceed as fol-
lows to customize the energy-saving plan settings:

1 Under Control Panel ▶ System and Security ▶ Energy Options,
open the system settings that specify the behavior when the power
switch is pressed or the computer is folded shut.
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2 Change the following settings:

￭ When pressing the power switch: Do nothing
￭ When pressing the energy saving button: Do nothing
￭ When closing the lid: Do nothing
￭ Enable fast start-up: Deactivated

NOTICE

To change the Turn on fast start-up option, you may need to enable
it first as an administrator. To do this, click on Some settings are cur-
rently unavailable in the window.

 

3 Open the energy-saving plan settings under Control Panel ▶ System
and Security ▶ Energy Options. Now click on Change advanced
energy settings.

 

4 Change the following settings:

￭ Under Saving energy:
– Deactivation after: Never
– Allow hybrid standby mode: Off
– Hibernate after: Never

￭ Under USB settings:
– Selective USB energy-saving settings: Disabled

 

5 If communication problems occur, proceed as follows:

Open the Device manager via the Windows start menu.

Maximize the USB controller entry.

Open the context menu of the USB controller used with the right mouse
button. Disable the Computer can switch off the device to save
energy option under Properties ▶ Energy management.

If it is not known which USB controller is used, then adjust the properties
of all USB controllers.

3 Single workplace installation

With the single workplace version StabNet Full, you can install the client and
the database on your computer.

1 Prior to the installation, disconnect all the USB devices from the computer
on which StabNet is to be installed.

If the OMNIS Software is already installed on the computer, exit the
Metrohm OMNIS DeviceServer service via the Windows Task Manager.
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2 Connect the USB flash drive with the StabNet installation file to the com-
puter and start the setup.exe file.

If the minimum system requirements are not met (see above), a corre-
sponding message appears. Click on [Yes] if you would like to install the
program nonetheless.

Afterwards, click on [Next >].

 

3 Read the license agreement for StabNet and accept it with [Yes].

 

4 After having accepted the license agreement, a window will appear
where you can enter the license code.

Enter the license code for StabNet Full and then click on [Next >].

NOTICE

If you have entered the license code of an update license, then the
license code of the previous full version will additionally be requested.

 

5 Confirm the target folder for the StabNet installation with [Next >] or
select a different target folder with [Browse…].

 

6 You can define the paths for the database files and default backup files in
the Additional installation information window:
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NOTICE

The default paths are different for the various operating systems.

The database path must not be on a network drive.

The default backup path may also be on a network drive.

You can change the ports StabNet uses to communicate with the data-
base server and the administration server with the [Advanced…] button.
If the ports are already used, an appropriate error message will appear.
Ask your system administrator for more information about this. Continue
with [Next >].

 

7 If you would like to create a shortcut on your desktop to start the Stab-
Net software, activate [Yes] and then click on [Next >].
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8 Confirm the program folder with [Next >] or select a different program
folder.

 

9 The installation settings can now be checked. Start the copy process with
[Next >].

 

10 The following message appears during the installation of StabNet:
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This message points out again which ports StabNet uses. Write down
these ports and inform your system administrator in case StabNet is not
able to connect to the database. Confirm the message with [OK].

StabNet will now be installed.

NOTICE

During the installation, all device drivers that are required for control-
ling the supported USB devices are installed or updated.

Anti-virus programs can prevent the unpacking of the device drivers. If
an error occurs, exclude the installation pathway for StabNet from the
virus scan.

If the driver software needs to be updated, a message appears. Con-
firm the installation by clicking on the [Install] button.

 

11 Once the copying procedure has been completed, you can make further
workplace settings:

The option This client ID must exist in the current StabNet system.
can only be activated if a database from a previous installation already
exists or if you want to connect to a database server on another com-
puter.

If you enable this option, then StabNet checks whether the identifier you
have entered exists in the database. If this is the case, the identifier and all
associated settings will be adopted. With this option, reinstalling a client is
much easier.

Click on [Next >]. If the database ports are not available, an appropriate
error message will appear and the installation will be canceled. In this
case, check your server and firewall settings before installing the program
again.
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12 At the end of the installation, the file info.txt will be created. This file
contains all relevant information concerning your current StabNet instal-
lation. Save this file on your hard drive for future reference and print it
(add to installation qualification).

NOTICE

An InstallLog file can be found in the installation directory of StabNet
under …bin\InstallLog. It contains a listing of all files copied to your
computer during the installation and a confirmation that the instal-
lation has been successfully completed.

 

13 Complete the installation with [Finish].

If the OMNIS Software is already installed on the computer, restart the
Metrohm OMNIS DeviceServer service via the Windows Task Manager.

Fonts

For the correct display of East Asian fonts (e.g. in reports), it may be necessary
to add the corresponding fonts. There are two options to do this. Carry out
only one of the two described options.

￭ Install the missing language: Windows Settings ▶ Time & Lan-
guage ▶ Language ▶ Add a language

￭ Download the fonts for all languages: Windows Settings ▶ Personaliza-
tion ▶ Fonts ▶ Download fonts for all languages

The procedure may differ from the described procedure, depending on the
Windows version and operating system build used. Additional information on
how to proceed can be found under Language packs for Windows.

4 Modifying/repairing/removing the installation
and upgrading the license

In order to carry out modifications on the current StabNet installation, start
the setup.exe file from the USB flash drive or click under:

Control panel ▶ Programs ▶ Programs and Features on Metrohm
StabNet. Then select Uninstall/Change:

https://support.microsoft.com/windows/language-packs-for-windows-a5094319-a92d-18de-5b53-1cfc697cfca8#WindowsVersion=Windows_11
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Modify

With this option you can adjust the paths to the database and backup files and
change the ports which StabNet uses for communication.

If the database path is changed, the existing databases are automatically
copied to the new location.

Repair/Update

With this option you can repair an existing defective installation or update an
older installation.

￭ Repairing the installation
In case of a defective StabNet installation because, for instance, a DLL file
is missing or a program file has been deleted by mistake, StabNet can be
repaired with this option.

￭ Updating the installation
In case an older version of StabNet is installed, it will be updated to the
new version of StabNet.

CAUTION

During the updating of older StabNet versions to StabNet 2.0, the databases
will be converted to the new version. Depending on the size of the data-
base, this may take some time. A progress bar showing the status of the
conversion is displayed for each database.

The computer must not be restarted or Windows shut down as long as the
conversion is running!

Remove

This option removes your StabNet installation. Data which has been gener-
ated after the installation (e.g. database entries, log files, exported data, etc.)
will not be deleted.
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5 Program update with StabNet Full

During the program update, the configuration database (system configuration,
methods, templates) and the determination databases are automatically
updated for further use.

NOTICE

The files in the database and backup directory will be retained when the
program is updated.

Files in the subdirectories bin, jre, lib, res, doc and examples will be over-
written by the update. The files in these directories which are not updated
during the update will be deleted. The deleted files are listed in the Install-
Log.

1 Save the configuration database to an external directory using the backup
function of StabNet. In the Configuration program part, select the
File ▶ Backup ▶ Manually menu item. Select Backup directory,
enter a name for the backup file and click on [Start]. The backup is car-
ried out. Then copy the backup file to an external storage medium.

 

2 If desired, export the methods in addition to the automatic backup with
the configuration database (see above) into an external directory. In the
Method program part, select the File ▶ Method manager... menu
item. Select the desired Method group, mark all methods to be
exported and click on [Edit] ▶ Export.... Select the desired export direc-
tory and click on [OK]. The methods are exported to the desired directory.
Then copy the method files to an external storage medium.

 

3 Save all determination databases created by you to an external directory
using the backup function of StabNet. In the Database program part,
select the File ▶ Database manager... menu item. Select the desired
database and click on [Backup]. Select Backup directory, enter a name
for the backup file and click on [Start]. The backup is carried out. Then
copy the backup file to an external storage medium.

 

4 Also save further files created by you in the installation directory (e.g.,
export files) to an external directory or to an external storage medium.

 

5 Close StabNet. Connect the USB flash drive with the installation file to
the computer and start the setup.exe file. Then select Repair/Update
program and click on [Next >].
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6 Enter your update license code and click on [Next >].

 

7 CAUTION

During the updating of older StabNet versions to StabNet 2.0, the data-
bases will be converted to the new version. Depending on the size of
the database, this may take some time. A progress bar showing the sta-
tus of the conversion is displayed for each database.

The computer must not be restarted or Windows shut down as long as
the conversion is running!

Complete the installation with [Finish].

An UpdateLog file with a list of all files that have been copied to your
computer during the program update and with a confirmation of a suc-
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cessful installation is saved in the StabNet installation folder (default:
C:\Program Files(x86)\Metrohm\StabNet) under bin\InstallLog.

6 User rights for StabNet

In order for the logged-in user to be able to access all functions with StabNet,
the Windows system administrator must ensure that the permissions are set for
the directories as listed below:

Directory Permission Group name or
user name

Database directory

Directory where the databases will be saved (…\Data).

Modify SYSTEM

User*

Backup directory

Directory where the backups will be stored (…\Backup).

Modify User*

%PROGRAMDATA%\Metrohm** Modify User*

Export directories

Directories where the exported files are to be saved.

Modify User*

PDF directories

Directories where the PDF files are to be saved.

Modify User*

Desktop Modify User*

Installation directory, e.g. %PROGRAMFILES(x86)%
\Metrohm\StabNet

Read & execute User*

Temp directory: %ALLUSERSPROFILE%\Metrohm
\Temp\StabNet

Directory where the temporary files are saved.

Modify User*

* User = name of the user who is logged in

** During installation of StabNet the permission Full Control is set for the following groups: SYS-
TEM, Administrators, Users, Guests, Main users.

NOTICE

The BackupServer.exe process must be started for carrying out a backup
(backup of the configuration database and of the determination databases).
You can check this under "Windows Task Manager".

The user must be logged in during the whole backup process.
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